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CREAZIONE DEL TEMPLATE BUILDER

Prima di far partire ADAMS/Car assicurarsi che il file acar.cfg mostri che si lavori in modalita expert

Start ADAMS/Car Template

Tools > database management > create database e creare un database nominato “SRT15”

Selezionare una directory in Database Path

File > Select Directory > SRT15.cdb

Tools > Database Management > Set Default Writable Database > SRT15

File > New Template: nominare il template “Front_Suspension_SRT15” ¢ inserire “suspension” in Mayor Role.

Cliccare su OK. Nel centro della finestra compare I’icona di gravita.

CREAZIONE SOSPENSIONE

La creazione di ogni elemento della sospensione avviene in tre step:

Creazione degli Hardpoints — Creazioni delle Parti — Creazione della Geometria;

1 Hardpoints Sospensione

Build > Hardpoint > New

Nella casella Hardpoint Name inserire “FUIBJ”. Assicurarsi che il Type € left (ogni entita va creata come left,
ADAMS/Car creera in automatico una coppia simmetrica rispetto all’asse centrale longitudinale).

La procedura si ripete per tutti i punti della sospensione. Di seguito si riporta il nome per esteso dei punti di tutta la
sospensione anteriore sinistra:

FUIBJ = front upper inner ball joint
LBJ = lower ball joint

RLIBJ = rear lower inner ball joint

FLIBJ = front lower inner ball joint
BJC = bellcrank joint chassis

BJ1 = bellcrank joint 1



BJ2 = bellcrank joint 2

ITRJ = inner tie rod joint

OTRJ = outer tie rod joint

WC = wheel center

UBJ = upper ball joint

RUIBJ = rear upper inner ball joint
SJC = spring joint chassis

SL = spring lower

PROJ = push rod outer joint

File Edit View Build Settings Tools Help

_Front_Suspension_SRT15 ~

Browse |Groups ]Fihers I

Hardpoints

= hpr_FUIBJ
= hpl_FUIBJ Hardpoint Name ~[FUIBJ
- All Other

Type @ left C right © single

Location [-172.-250,288

Table | oK Apply Cancel

Search




File Edit View Build Settings Tools Help

_Front_Suspension_SRT15 + Front_Suspension_SRT15

Browse IGioups ]Fillers I

=--[=+Hardpoints
- = hpr_RUIBJ
= hpl_RUIBJ
s hpr_UBJ

- = hpl_UBJ
s hpr WC

- = hp_WC

- a hpr_OTRJ
= hpl_OTRJ
= hpr_ITRJ

- = hpl_ITRJ

- a hpr_BJ2
= hpl_BJ2

- = hpr_BJ1

-~ = hpl_BJ1
= hpr_BJC

~ = hpl_BJC

-~ = hpr_FLIBJ
= hpl_FLIBJ

= hpr_RLIBJ

- = hpl_RLIBJ
= hpr_LBJ

~ = hpl_LBJ

-~ = hpr_FUIBJ
= hpl_FUIBJ

All Other

Search

Nella seguente tabella si riportano tutti gli Hardpoint creati.

ELEMENTO SOSPENSIONE NOME HARDPOINT COORDINATE LEFT (X,Y,2)
Triangolo superiore FUIBJ -172,-250,288
Triangolo inferiore LBJ 12,-580,159
Triangolo inferiore RLIBJ 179,-194,95
Triangolo inferiore FLIBJ -186,-193,82

Bellcrank BJC 9.5,-200,522
Bellcrank BJ1 9.5,-274,572
Bellcrank BJ2 9.5,-216,573
Tie Rod ITRJ -55,-235,123
Tie Rod OTRJ -82.5,-591,190
Portamozzo wWC 7.5,-630,260
Triangolo superiore UBJ 31,-566,386
Triangolo superiore RUIBJ 207,-255,293
Molla SJC 9.5,-20,556
Molla SL 9.5,-19.039,571.269
Punto di riferimento SJc2 0,-20,556

2.1 Parti Triangolo superiore e inferiore

Il secondo step prevede la creazione delle parti della sospensione
Build > Parts > General Part > New

General Part. Upper_Control_Arm



Material Type: Steel

Per il triangolo inferiore la procedura € identica.

Parte Location
Upper_Control_Arm UBJ
Lower_Control_Arm LBJ

LY Create General Part

General Part l Upper_Control_Arm
Type & left  right ¢ single

Location Dependency l User-entered location

'Location values [310, 566.0, 386.0

Orientation Dependency I User-entered values j

Orient using & EﬁlerAngles ¢ Direction Vectors

Euler Angles ] 0.0.0
X Vector [1:00000
Z Vector |0,0.0,0,1 0

Mass| 1
Ixx| 1 [~ Off-Diagonal Terms

lyy |17
lzz [1——

CM Location Relative to Part l

Density & Material © User Entered

Material Type .materials_steel . l
OK Apply | Cancel |

2.2 Geometria Triangolo superiore e inferiore

Creata la parte del triangolo superiore si passa a definire la geometria dei braccetti.
Build > Geometry > Link > New

Creare la geometria come segue:

Triangolo superiore

Link Name: Front_Upper_Link



Link Name: Rear_Upper_Link

Radius: 6.5

Link Name | Front_Upper_Link

General Part l ._Front_Suspension_SRT15.gel_Upper_Control_Arm

Coordinate Reference #1 I ._Front_Suspension_SRT15.ground.hpl_FUIBJ

Coordinate Reference #2 I ._Front_Suspension_SRT15.ground.hpl_UBJ

| Radius [10

Density ¢ Material € User Entered
Material Type steel Y ‘

‘ oK Apply Cancel | ‘

} Color dark gray >

Con la stessa procedura si ricava la geometria del triangolo inferiore.

2.3 Parte Portamozzo

Per velocizzare la procedura di creazione della sospensione € possibile utilazzare il commando Wizard che permette di
creare in un unico passaggio sia la parte che la geometria di un elemento della sospensione.

Build > Parts > General Part > Wizard

General Part Name: Wheel_Carrier

Parte Location
Wheel_Carrier WC
Wheel_Carrier LBJ

Wheel_Carrier UBJ




General Part Name | Wheel_Camer
Type @ let © nght O single

Geometry Type |Arm 'l

Coordinate Reference #1 r_me_Suspension_SRTIS ground hpl.
Coordinate Reference #2 |._Front_Suspension_SRT15.ground hpl
Coordinate Reference #3 | _Front_Suspension_SRT15 ground hpl

Thickness [10

Color red v

Density & Matenal ¢ User Entered
Matenal Type [ matenals aluminum

= o |ty |_caca |

2.4 Geometria Ackermann

Si aggiunge alla parte Portamozzo la geometria Ackermann che é un collegamento tra portamozzo e braccetto di sterzo.
Build > Geometry > Link > New

General Part. Ackermann

Material Type: Steel

Radius: 4

2.5 Parte Tie Rod

Build > Parts > General Part > New

General Part: Tierod



p

n Modify General Part
General Part

&R
I ._Front_Suspension_SRT15.gel_Tierod
[6‘ left € right © single

Type

Location Dependency IUser~entered location

&

Location values |-82.5, 591, 190

Orientation Dependency IUser-entered values

5l

Orient using /¢ Euler Angles ¢ Direction Vectors
Euler Angles [0.0.0.0,0.0
X Vector [10.0.000
Z Vector [000010
Massl 1.0

Ixxl 1.0

[ Off-Diagonal Terms

tyy[1.0
lzz[ 1.0

|0.0.0.0.0.0

CM Location Relative to Part

Density 15 Material ¢ User Entered

Material Type I

v

OK

Apply | Cancel I

~

2.6 Geometria Tie Rod

Build > Geometry > Link > New

Link name : Tie Rod

Con I'utilizzo del comando Wizard, sarebbe stato possibile creare ugualmente il Tie Rod.

2.7 Parte Push Rod

Build > Parts > General Part > New
General Part. Push_Rod

Material Type: Steel



Parte Location

Push_Rod LBJ

IPush_rod
Type :(0‘ left € right " single
Location Dependency I User-entered location j
| Location values | 12.0, -680.0, 159.0 ]
6rientation Dependency I User-entered values :] |
;Orient using (: Euler Angles ¢ Direction Vectors il
|Euler Angles I 0,00
|X Vector [1.0.0.0.0.0

|Z Vector [0.000.10

MassT1—r 7 ‘
lxxl1— [~ Off-Diagonal Terms
-
lzz [1—

CM Location Relative to Part I

Density /& Material ¢ User Entered

Material Type materials.steel .
OK Apply l Cancel I

2.8 Geometria Push Rod

Build > Geometry > Link > New

Link name : Push_Rod



Link Name I Push_rod

General Part I ._Front_Suspension_SRT15.gel_Push_r

Coordinate Reference #1 ] ._Front_Suspension_SRT15.ground.hpl_

Coordinate Reference #2 l ._Front_Suspension_SRT15.ground.hpl_
Il Radius |6.5

Color dark gray 'I

v Calculate Mass Properties of General Part
Density & Material © User Entered

Material Type I steel vl

oK | Apply | cancel

2.9 Parte e Geometria Bellcrank

Build > Parts > General Part > Wizard
General Part. Bellcrank

Material Type: Alluminium

Parte Location
Bell_Crank BJ1
Bell_Crank BJ2
Bell_Crank BJC

Link Name | Push_rod

General Part | ._Front_Suspension_SRT15.gel_Push_r

Coordinate Reference #1 | ._Front_Suspension_SRT15.ground.hpl_

Coordinate Reference #2 | ._Front_Suspension_SRT15.ground.hpl_
|6.5

dark gray v

v Calculate Mass Properties of General Part

Density & Material ¢ User Entered

Material Type steel v

OK I Apply ‘ Cancel



2.10 Creazione parte dello stelo dello smorzatore

Di seguito si crea lo stelo dell’ammortizzatore, con lo stesso procedimento adottato per le Parti create in precedenza.

Build > Parts > General Part > New
General Part. Strut

Material Type: Alluminium

Parte Location

Strut SJC

General Part I Strut

Type & left © right ¢ single

Location Dependency I User-entered location L]
Location values [9.5. 20,0, 856.0

Orientation Dependency I User-entered values :j
Orient using |6 Euler Angles ¢ Direction Vectors
Euler Angles I 0,0,0

X Vector [10.0000

Z Vector |0,0.0.0 1.0

Mass| 1
Ixx| 1 [ Off-Diagonal Terms

.
lzz ﬁ

CM Location Relative to Part |

Density & Material © User Entered

Material Type -materials_aluminum .

E oK Apply l Cancel |

2.11 Creazione parte del corpo dello smorzatore

Dopo avere creato lo stelo, si passa alla realizzazione del corpo dell’smorzatore.



Build > Parts > General Part > New
General Part. Strut_outboard

Material Type: Alluminium

Parte Location

Strut_outboard BJ2

n Create General Part

General Part | Strut_outboard

Type @« left © right  single

Location Dependency l User-entered location LI

Location values | 9.5, -216.0, 573.0

-
Orient using IS Euler Angles ¢ Direction Vecto}s
Euler Angles I 0.0,0

X Vector [1.0.0.0,0.0

Z Vector [0:0.00.1.0

Orientation Dependency I User-entered values

[~ Off-Diagonal Terms

lyy |1—
lzz l17

CM Location Relative to Part I

Density & Material ¢ User Entered

Material Type -materials.aluminum .
OK Apply l Cancel I

212 Creazione della Damper Force

Dopo aver creato le due parti che definiscono lo smorzatore, si procede a definire la forza che agisce tra esse. In
ADAMS/Car ¢ presente la curva forza-velocita dello smorzatore che € comunque personalizzabile.

Build > Forces > Damper > New



Damper Name l Damper

| Part ] ._Front_Suspension_SRT15.gel_Strut

| J Part I ._Front_Suspension_SRT15.gel_Strut_outboard

| | Coordinate Reference l ._Front_Suspension_SRT15.ground.hpl_SJC

| J Coordinate Reference l ._Front_Suspension_SRT15.ground.hpl_BJ2

| Property File l mdids://acar_shared/dampers.tbl/mdi_0001.dpr

| Color maize v
Damper Diameter Kl |

15

2.13 Creazione della molla

Per creare la molla é stato necessario creare I’hardpoint SL che definisce la posizione della sede inferiore della molla.
Inoltre bisogna definire le seguenti specifiche:

e | due corpi tra cui agisce la forza elastica

e Uno specifico punto nel quale la forza é applicata

e Lalunghezza d’installazione della molla, che viene usata per ottenere il precarico progettato sulla molla

e Un property file che contiene le informazioni di lunghezza libera, nonché la caratteristiche forza /
deformazione della molla.

ADAMS / Car calcola la forza esercitata dalla molla con le seguenti equazioni:

C =FL - IL + DM’(i,j)
Force = -k(C - DM(i,j))

dove:

e C & una costante.

o FL ¢ lalunghezza libera della molla, come definito nel property file.

e |L élalunghezza d’installazione.

o DM’(i,j) ¢ la distanza iniziale tra le coordinate i e j dei punti. Se s’inserisce un valore minore per DM(i j),
ADAMS/Car calcola un incremento del precarico per la molla. Al contrario, se s’inserisce un valore maggiore,
ADAMS/Car calcola un decremento del precarico.

e DM(i,j) ¢ lavariazione della lunghezza della molla tra le coordinate i e j dei punti al progredire della
simulazione.

e Force ¢ la forza della molla.

o K larigidezza non lineare della molla derivata dal property file.

Per creare la molla:



Build > Forces > Spring > New

Spring Name | Spring

| Part I ._Front_Suspension_SRT15.gel_Bellcrank

J Part I ._Front_Suspension_SRT15.gel_Strut

| Coordinate Reference I ._Front_Suspension_SRT15.ground.hpl_SL

J Coordinate Reference I._Front_Suspension_SRT15.ground.hpI_SJC

Installed Length L” 122 DM(iCoord,jCoord)

Property File I mdids://acar_shared/springs.tbl/mdi_0001.spr
Color dark gray v
30

Spring Diameter 2

Number of Coils

2.14 Creazione delle variabili Toe e Camber

I Toe e il camber sono variabili usate entrambe per I’analisi della sospensione. ADAMS/Car le crea in unico step per
guesto motivo.

Build > Suspension Parameters > toe/camber Values > Set

Right Side

Toe Angles ] 0.0
Camber Angles ] -1

Apply ' Cancel

2.15 Creazione del mozzo

Prima di procedure alla creazione della parte del mozzo, bisogna creare un construction frame, ovvero un insieme di
elementi di ADAMS/Car che si usano ogni volta che un’entita richiede un orientamento in aggiunta a una posizione.
Si crea il mozzo basandosi sul construction frame e poi la geometria ad esso associato.

Build > Construction Frame > New



A

Construction Frame I Hub_Bearing

& left © right ¢ single

I Delta location from coordinate :_]

| ._Front_Suspension_SRT15.ground.hpl_WC

Location [0.00

Location in /& local ¢ global

Orientation Dependency l Toe/Camber _'J

‘Variable Type l Parameter Variables LI

Toe Parameter Variable

| ._Front_Suspension_SRT15.pvl_toe_angle
|._F

Camber Parameter Variable

ront_Suspension_SRT15.pvl_camber_angle

Apply Cancel |

2.16 Creazione della parte del mozzo

Build > Parts > General Part > New

General Part. Hub

Material Type: Alluminium



n Create General Part

General Part I Hub

Type @« left ¢ right © sing|e-

Location Dependency I Delta location from coordinate :_]

Coordinate Reference I ._Front_Suspension_SRT15.ground.cf_Hub_Bearing

Location I 0,00

Location in (3 local " global

| Orientation Dependency | Delta orientation from coordinate L]

Construction Frame I ._Front_Suspension_SRT15.ground.cfl_Hub_Bearing

Orientation I 0.0.0

[~ Off-Diagonal Terms

Iyy[1—

CM Location Relative to Part |

lzz|1

Density ifo‘ Material ¢ User Entered

Material Type _materials_aluminum .

Apply Cancel

217 Creazione della geometria del mozzo

Build > Geometry > Cylinder > New

Cylinder Name: Hub

Cylinder Name | Hub

General Part | ._Front_Suspension_SRT15.gel_Hub

Construction Frame | ._Front_Suspension_SRT15.ground.cfl_Hub_Bearing
Radius I 33

|30

|
dark gray 'I

| v Calculate Mass Properties of General Part

}(0‘ Material ¢ User Entered

aluminum v

Apply Cancel



2.18 Creazione dei Mount
Prima di creare i giunti bisogna creare i mount parts che rappresentano le parti di montaggio degli elementi della
sospensione al telaio. Queste parti sono prive di masse e di default sono fissate al suolo.

Build > Parts > Mount > New

Si riporta il mount del triangolo superiore:

Mount Name | m_FuIBJ
Coordinate Reference I ._Front_Suspension_SRT15.ground.hpl_FUIBJ

From Minor Role | inherit

| Apply Cancel

Lo stesso procedimento € applicato per i seguenti mount parts: Triangolo inferiore, attacco sterzo, attacco bellcrank -
scocca , attacco smorzatore — scocca.

3 Giunti

Una volta creati le parti, le molle, e gli smorzatori, & possibile definire i giunti che collegano i vari elementi della

sospensione.

Build > Attachments > Joint > New



Joint Name

| Part

J Part

Type

Joint Type

Active

Location Dependency
Coordinate Reference
Location

Location in

Orientation

EE

| sph_Arm_Lower_Outer

| ._Front_Suspension_SRT15.gel_Wheel_Carrier

I ._Front_Suspension_SRT15.gel_Lower_Control_Arm
@ left ¢ right © single

spherical hd

& always ¢ kinematic mode

IDeIta location from coordinate j

| _Front_Suspension_SRT15.ground.hpl_LBJ

[0.00
@ local T global

None M

Apply

Cancel

GIUNTO | PART J PART
spherical Wheel Carrier Lower Control Arm
revolute Lower Control Arm Chassis (Mount M_FLIBJ)
revolute Upper Control Arm Chassis (Mount M_FUIBJ)
spherical Wheel Carrier Upper Control Arm
spherical Push Rod Lower Control Arm
spherical Wheel Carrier Tie Rod
hooke Tie Rod Chassis (Mount M_OTRJ)
convel Push Rod Bellcrank
revolute Bellcrank Chassis (Mount M_BJC)
convel Bellcrank Strut outboard
revolute Wheel Carrier Hub
cylindrical Strut Strut outboard
Convel Strut Chassis (Mount M_SC)




4  Creazione dell’asse di sterzo

Nella sospensione double whishbone 1’asse di sterzo ¢ individuato dalla congiungente i due giunti sferici del
portamozzo.

Build > Suspension Parameters > Characteristic Array

Steer Axis Calculation Geometric b
Suspension Type Independent v

| Part | ._Front_Suspension_SRT15.gel_Upper_Control_Arm

J Part I ._Front_Suspension_SRT15.gel_Lower_Control_Arm

| Coordinate Reference I ._Front_Suspension_SRT15.ground.hpl_UBJ

J Coordinate Reference | ._Front_Suspension_SRT15.ground.hpl_LBJ

OK Apply Cancel

Eile Edit View Build Settings Tools Help




5 Creazione dell’output Communicator

Per simulare la sospensione € necessario collegarla al banco di prova (test rig). Per fare questo bisogna definire i
communicators che collegano il mozzo al test rig nel centro ruota come di seguito:

Build > Communicator > output > New

Output Communicator Name | suspension_mount

Matching Name(s)

| left ¢ right ¢ single

i mount VI
A8 To Minor Role inherit VI

I ._Front_Suspension_SRT15.gel_Hub

Part Name

List Inputs Apply Cancel |

Il secondo Communicator mette in comunicazione il test rig della sospensione con 1’ upright part (Wheel Carrier).

Output Communicator Name | suspension_upright

Matching Name(s)

@ left © right ¢ single

mount 5
inherit Y

I ._Front_Suspension_SRT15.gel_Wheel_Carrier

Il terzo Communicator serve a indicare dove avviene il collegamento.



A
. & = 3

Output Communicator Name ]wheel_cemer

Matching Name(s)

Type [& 1eft © right singlé

@l Entity location v
Alll To Minor Role inherit A
- ————————

| Coordinate Reference Name | ._Front_Suspension_SRT15.ground.hpl_WC

List Inputs

6 Salvataggio del Template e creazione del SubSystem

Salvare il Template appena creato (File > Save as > OK) e chiuderlo. Successivamente si passa nello Standard
Interface.

Tools > ADAMS/Car Standard Interface

In questa sezione si crea il Subystem della sospensione che si basa sul template che ¢ stato realizzato.

File > New > Subsystem

B New Subsystem =]
Subsystem Name | Front_Suspension_SRT15

Minor Role I front j
Template Name I mdids://SRT15/templates.tbl/_Front_Sus

[~ Translate from default position
I Fore Translation _'JI
IUpTransIatlon jl

OK Apply Cancel

Infine si crea 1’assembly:
File > New Suspension Assembly

Assembly Name: FRONT_SRT15



